
 

                                     3D Shooting game Workshop 
 
 
 

For Newbies 
Foreword   
 
Dear reader, 
 
I created this workshop for the newbies who want to make a quick 3d shooting game 
that explaines the most basic functions. 
When this game is finished  you have learned how to : 
 

- Build,Creating,Texturing rooms. 
- Create player entity and enemies. 
- Create actions like : Shooting at enemies, Killing them, Exploding objects. 
- Adding an elevator,combining wdl files. 
- Change the line when you get your gun. 
- Adding sound and music to your level 
- Making entities speak to you,Create score number health,ammo 
- Player can die, Creatingh a healthbar,Getting your health back 
- Using water 
- Creating weather. (Snow) 

 
When your done your no expert but you will know most basic stuff that 3DGS offers. 
Good luck, If you have any questions please put them in the forum to realspawn or mail 
me at renepol@zonnet.nl Special thanks to MARTY BEE who helped me excellent to  
create this tutorial. And also did some spelling checking Download all the stuff you need 
at  
 
 
                                           http://home.wanadoo.nl/pol.rene/newbie.html 
     DOWNLOAD SECTION 
 

 
Importand ! You’ll need the following stuff in your workfolder. 

 
Snowmap.wdl – Snow.pcx – Held.mdl – Cbabe.mdl – Crate.mdl – Waffe2.wdl 

Lampe.wdl - Exploder.wdl – Beet.mid – Water.wav – nothing.wave – Alien.mdl – 
health.pcx – Med.mdl –War4.wdl-mypanels.wdl-lift1.wmb-porta.wmb-am.mdl 

You can download the total zip file  from my site 
Before you start open the offiche.wdl with note pad and save 

It as shoot.wdl 
Why ? Well the offiche has all basic stuf allready in it so we can use it. 

Open up shoot.wdl with notepad and search for the line : load_level (<office.wmb>); 
Change office.wmb into shoot.wmb 

This is our game name save it 
 

mailto:renepol@zonnet.nl
http://home.wanadoo.nl/pol.rene/newbie.html


  

 

01. Creating the room. 
 

- Open wed and click  : File > New 
- Pull out the top view so it fills your workspace. (1) 
- Click :  Object > Ad primitive > Cube large. 
- Scale the cube so it fills your top view. (12th Button) 
- Click : Edit > Hollow block. 
- Pull back the top view to its original size (2) 
- Click : Texture > Texture manager  
- Click : Add wad and select the standard WAD. (3) 
- Close texture manager 
- Click on the room so it will be highlighted red. 
- Go to the textures on the right and right click  Gate1 
- Choose apply 
- With the room still selected click : Object > Scope  > Scope down 
- Select the top of your room and press delete 
- Click Object > Scope > Scope up 
- Click Build and make sure level map is selected 
- Now you have created a simple room with no top. Later we will ad 
      A sky to it (4) 
- Click File > Save As, and save it as shoot 
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01. Adding entities. 
 

- Open wed and click  : File > Open > Shoot. 
- Click : Object >  Load Entitie > Cbabe.MDL 
- The model will appear place it in the middle of the room on the ground. (1) 
- Repeat this with the Held.MDL and the Waffe2.MDL 
- Click : Build and you will see the room with the entities. (2) 
- Our level needs a WDL script. Click : File > Map properties 
- Click :  ndf and replace it for your made shoot.wdl 
- Close Map properties 
- Select the Cbabe model and right click Give it the Player_walk action. 
- Select the Held model and right click Give it the Robot2  action. 
- Select the Waffe2 model and right click Give it the Gun  action. 
- Click build room and make sure entities is selected 
- Click run and your entities will be acting as you wanted. (3&4) 
- Press F7 to change players view (5) 
- Notice the enemie is shooting at you but you wont die, this part comes later. 
- After you hit the enemie serveral times it will explode this is because we gave 

it the robot 2 action  (6) 
-    You can fire with CTRL and pick up the gun by walking into it. 
- By giving the entities actions we’ve allready did some programming the actions are 

Taken right in to the WDL file of our level. 
- Save your level 
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02. Splitting 1 room into 2 using a door. 
 

- Open wed and click  : File > Open > Shoot 
- Click : Object >  Ad primitive > Large cube 
- Scale it and place it in the middle of the room so you have 2 room splitted 
      By this wall (1) 
- Texture the wall with Heavy Metall 
- Click : Build and you will see the room splitted into and divided by a metal wall (2) 
- Click : Object > Add primitive > Cube small 
- Place the cube in the  middle of the wall you just made. Place it on the ground 
      and make sure it sticks out both sides of the wall. Make it bigger so your  
      player can walk through it. (3) 
- With the cube selected click : Edit > CSG substract 
- Click delete. A doorway has now been created 
- Click build and see the doorway in your level. (4) 
- Click : Object > Load entitie > Open Porta.WMP its in your work folder. 
- Place it voor the doorway. (you have to do some building to see if it fits) 
- For now it doesnt matter if it fits correctly as we are only learning how to place 
      a door. When you placed it right built your level and see the door. (5) 
- Richt click the door and give it the door action. 
- Built your level make sure entities is selected, Then run it. 
- Walk to the door and when your near press space bar. The door will  
      open and close. (6)  
- We did again some scripting by giving the door the door action. 
- Save your level 
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03. A finishing touch, adding sky,walls,roof. 
 

- Open wed and click  : File > Open > Shoot.WDL 
- Create a wall like you did before scale it and place it in your level  

add the texture platemetal to it.  copy this wall and make more of 
them. Scale them in different sizes, make sure the hight is the same as  
the room. Place the walls as shown (1) 
Copying a wall can be done by pressing ctrl when the wall is selected so  
You can drag a copy out of the original. 

- Copy the held model the same way so there is a total of 3 held models. 
- Place the held models as show. The red dots are the held modeld (1) 
- Place the Cbabe model as shown. The red Dot (1) 
- Place the Waffe2 model as shown The yellow Dot. (1) 
- Built the level and see how you created a maze like room.  
- Now we are going to make a roof for one side of the rooms 
- Click object > Add primitive > Large cube. 
- Scale it so it fits on 1 side of the room make it flat. (2) 
- Add the texture Lightwall1 to it 
- Built and see your room has a roof  (3) 
- Time to make the other room outside so let’s create a sky 
- Click object > Add primitive > Large cube. 
- Scale it so it covers the rooms completly (4) 
- Click : Edit > Hollow block. 
- Now add the texture skyblue to it 
- Built and see the sky is shown in the seccond room (5) 
- To walk through build and select entities. Run it wow looks smooth. 
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04 . It snows in the room without a roof. 
 
- Open with note pad your shoot.WDL file.   
- We have added a snow.wdl to your work folder and were going to include it 

In our shoot.wdl 
- Now ad the following line at the end of your shoot,wdl file 
- Include <snowmap.wdl>;  
- Save it under the same name (shoot.wdl) 
- Open wed and click  : File > Open > Shoot.WDL 
- We need an object  to make our snow fall 
- Click : Object >  Load Entitie > Lampe.MDL 
- Place the lamp above the room without a top 
- Rightclick the lampe and give it the snowfall action make sure you  make  

      the lampe invisible. (1) 
- Copy the lamp serveral times (2) 
- Built and select enties, Run and see it snow outside (3) 
 

 
 
 

 
 
 
 
 
 
1            2            3   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



  

05 . Changing the music in your level 
 

- Open with notepad your shoot.wdl file 
- Search for the line : MUSIC testsong = <ribanna.mid>; 
- Change ribanna.mid into beet.mid  and save 
- No open your level in wed built and run and you’ll hear the midi file 

Playing we just added. 
 
 

06. Changing your opening screen 
 

- This game uses the logodark.bmp picture in your template folder. 
- Change this picture in any photo editing program and save it keeping the 

same place and name 
- In wed open your game built and run and see your screen appear 
 
 

07. Exploding boxes. 
 
- Open your shoot.wdl again with note pad. 
- Add the exploder.wdl as you learned before. So add this line at the end 

of the wdl 
- Include <exploder.wdl> 
- Save it 
- Open your level in wed and click : Object > Load entity and open the crate.mdl 
- Place it against the wall near the gun (1) 
- Right click the crate and give it the exploder action 
- Built and run you level. Pick up the gun and shoot on the crate (2) 
- It will explode. it cant kill you now but will do some damage against your 

enemies. (3) 
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08. Creating water and adding sound to it. 
 

- Open up your level in wed 
- Now create 2 cubes and scale them along the wall make them low so the 

player can look over it. Make 1 cube a little higher. (1) 
- Texture the first on with Giger and the seccond with water 1 
- Built and check it out it has to look like picture (2) 
- Click object > Load sound and open water.wave 
- A  red cone shape will appear. (3) 
- Drag this into the  water texture 
- Built and run 
- When you walk closer to the water you’ll hear the water running. 
- The closer you get the louder the sound is. 
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09. Creating an elevator. 
- Open up your level in wed 
- If you want to know how to built a elevator go to my site and check the tutotial 

for now we use the elevator that allready excist.  
- Click object > Load map entitie > open lift1 
- A red square will appear this is the elevator, Place it in the room without the  
      roof on the ground. (1) 
- Built level and you’ll see the elevator (2) 
- Rightclick the elevator and use the following settings : skill 5 = 3  skill 6=36 

skill 3 = 300 give it the elevator action 
- Build and run you level when you get on the elevator it takes you up so you 

can see your room from up there. (4) 
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10. Your player can die. 
 
- Offcourse you player is still inviseble so were going to add a script that maked 

Our hero die if it’s been shot serveral times. 
- open with notepad shoot.wdl and copy the following code after the last line. 
- ACTION player_prog 

{ 
MY.NARROW = ON; // use narrow hull! 
MY.FAT = OFF; 
MY.TRIGGER_RANGE = 5; 
MY._MOVEMODE = _MODE_WALKING; 
MY._FORCE = 0.75; 
MY._BANKING = -0.1; 
SET MY.__STRAFE,ON; 
SET MY.__BOB,ON; 
SET MY.__TRIGGER,ON; 
CALL player_walk; 
CALL player_fight; 
CALL drop_shadow; 
} 

- Save it 
- Open your shoot level in WED and give your player the Player_prog action (1) 
- Built and run it. No your in danger so shoot them before the kill you. (2) 
- Warning the exploding crate can hurt you to so run away when it’s  been hit.  
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11. Changing the line when you player gets   
      the gun. 
 
 
- Importand do as i explain step for step otherwise you’ll ruin your original 

weapons.wdl. 
- Open up  weapons.wdl with note pad. (it’s in your template folder.) 
- Search for the line : STRING got_gun1_str,"Got a small gun!"; 
- Change teh Got a small gun ! line into Let’s kill some enemies 
- Save it as weapons2.wdl in your work folder 
- Open up your shoot wdl in notepad. 
- Now add the next line at the end of the shoot wdl 
- Include <weapons2.wdl>; 
- Save it 
- Built and run you level. When you pick up your gun the text will appear. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



  

12. Making entities speak to you. 
 
- Open your shoot wdl in wordpad 
- Were going to add a code to let an entitie speak to you when you get  

Close to it. 
- Add the following code at the end of your WDL 

} 
SOUND whammy <nothing.wav>; 
/////////////nothing 
function speech_event() 
{ 
IF (YOU == PLAYER) 
{ 
MY.EVENT = NULL; 
PLAY_SOUND, whammy, 70; 
WAIT 1; 
} 
} 

  ACTION detect_entity 
{ 
MY.ENABLE_TRIGGER = ON; 
MY.TRIGGER_RANGE = 400; // talk range 
MY.EVENT = speech_event; 
} 

- Save it 
- Open up your level and place the alien model at the end of the hall near the 

Water. (1) 
- Give it the Detect_entitie action (This code we just inserted in the wdl) 
- Build and run. When you get close to the alien the dude will say : 
- DONT MIND ME I KNOW NOTHING..... (2) 
- MY.EVENT = NULL; plays the line only once. 
- If you delete this line the sound will repeat continuesly. 
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12. Creating a health bar. 
 

- Open your shoot wdl and copy the following line at the end of the wdl 
} 

 bmap health_map = <health.pcx>;  
panel hbar_pan  
{  

     hbar 20, 20, 230, health_map, 1, player._health;  
     flags = refresh, visible, overlay;  

} 
- This code is going to show the healthbar and every time your  
      hit it’s becoming smaller untill there is nothing left. And then...Your dead 
- Save it 
- Built and run your level and see hoe you created a healthbar. (1&2) 
- You can easiely make your own heathbar just save it as health.pcx in your 

work folder. 
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13. Getting your health back. 
 

- Open you level in Wed  
- Click Object > Load entitie > Open med.mdl 
- Place it some where in you level 
- Richt click the med and give it the medipack action 
- Build and run you level 
- Let you self be shot and then run for the med.. You will get some 

Health back... (1) 
- Tip : If you select flag 1 in the action menu the med model will rotate in your 

game, The same thing works for the gun 
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14. Making a simple score menu. 
 

- Open up the shoot.wdl in note pad. 
- Delete this line : include <war.wdl>;      // remove when you need no fighting 
- We do this because we are going to inser our own score and using the war4 

wdl that marty bee created for us. 
- Now were going to include 2 more wdl.files in your main wdl. 
- After the include wdl files lines type this 
- include <mypanels.wdl>; 
- include <war4.wdl>; 
- We’ve now included a score code. 
- Save it open your shoot level built and run 
- Now you see the score on the screen as the game begins 
- 0 = Ammo 100 = Youre health 0 = Score 
- Everytime you kill an enemie you should get 100 points. (1) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

15. Making ammo running out and getting            
      ammo back. 

- Oke score works, Health works, so let’s make the ammo work. 
- Richt click the gun and change skill 4 into 2.25 (1) 
- Place the am.mdl in your level richtclick it and give it the Ammopack action 
- Rightclick the am.mdl and change skill 4 into 2 (2) 
- Built and run level when your out of bullets get the ammopack and you’ll 
     receive the ammo. 
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Oke From now your on your own. 
You are now able to do more with 3DGS then you imaged. 
 
Try to Experiance:  
 
look for the sound lines for fire a gun and change it into other sounds 
Add machine sound to the elevator 
Import your on models and give them exploding actions 
Create your own health bar 
Change messages 
Make your own doors,rooms,levels,elevators 
Add  your own midi file to it 
Change the snow.pcx into something eles (fire,Ice,Rain) 
Change the bullets 
Its all up to you !!!! 
 
 
 
Visit my site for more up to date tutorials 
 
Thanks for using my workshop. Please mail me if you used it give me a reason to  
Keep on going. 
 
See yah 
 
Realspawn 
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