Creating your own Texture

Hi there. As a starting game builder I know the importance of good tutorials, | also know the
fact when everybody contribute and write about his or her specialty or things they know the
tutorials about game building will grow. And that is just what we need!

Also writing about things, makes you better and it learns you a lot. In most cases you will
improve your knowledge when you write it down. Now | am not English so | hope people
don’t mind my typos and bad choice of words sometimes. It is all about what | have to tell not
about how | tell it.

Making your own textures is a big part of the fun in making 3D. As a programmer | became
interested in 3D some 15 years ago. | start learning 3D Studio and recently I start using Maya
but my real interest is game building but | am still a new be in that department.

People that know 3D also understand the importance of texture. It is the texture that gives our
subjects the looks we want. The importance of good texture grows the smaller the polygon
counts become. Low polygons need better texture and this is even more important for a 3D
game.

What do we need?

Well for creating good looking texture, you don’t need a lot. But I use the following.

e Adobe Photoshop: Most of us have this software, and when you don’t believe me this
is software you want! | know it is expensive but it still is the best tool for the job. You
can use other software, but for the tutorial I use Photoshop. | am not familiar with
different software so don’t write me about how to do things using other tools!

e A good digital camera. Well you don’t really need this. You can find pictures on the
web. But hunting for your own pictures is a part of the fun to.

e A Graphic Tablet. Now if you get serious about building games and do a lot of
graphics this is something to consider buying! You don’t need it you can do
everything with the mouse. But using the pen is making things easier. Just like digital
camera’s the prices of this hardware dropt immense in resent years. Maybe a good
idea in your letter to Santa.

So the only thing you really need is Photoshop all the rest are just handy tools.

Seamless texture.

| start thinking about this tutorial when I needed texture for my 19" century London level in
my game Time Hoppers. Like for most levels it is difficult to find the exact texture you want.
So it was the time to start up Photoshop, and look at the pictures | made on a trip to London.
Is there a better place to get the exact texture then the original? Well I don’t think there is.
London has a typical building stile and this comes with a lot of texture for us.

The first thing | wanted was a rooftop for my houses in the London streets of my level. The
first thing about this is the fact | wanted it to be seamless. But pictures rarely are seamless so
we need to make it like that.



This is the picture | use to take the
rooftop texture from. Like you can see
we have a few rooftops on the picture,
and they all have a different look. The
texture | want is the one on the house at
the right at the picture.
This has the bumpy look | want in my
London level. The only problem we
have is the fact we don’t have much of
it, so we need a way to replicate it. And
this is where we need a seamless
texture. The ldea to make it seamless

o b makes it more useful for building all
the roofs we have in the level. Not to mentlon about the advantage of reusing it in the future
over and over again.
Needless to tell this is not the real size of the picture. | used the original size for capturing the
part | needed. Use the rectangular marquee tool for selecting what you want and move it into
a new picture project using the move tool. Make that new project bigger then your selection
this is important, because we need to do some manipulations with it.
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Now this is what | selected. Now a few things we notice
here.

1. The rows are not strait.
2. The angle is not 100% correct.
3. Iselected it to big.

Now point 3 is logical, we need to manipulate it in
something we can use. This is the reason we select much more then we really need. The first
thing we want to do at this point is make the rows strait. A useful thing to do this is make use
from the show grid option we can find in the view menu. View->Show->Grid. Or we can use
the shortcut CTRL +

[y | To strait out the rows we use the rotate
option. You can find this in the transform
options of the Edit menu.
Edit->Transporl->Rotate. At the picture
you can see using the show grid is a big
help for this kind of work.

Like you can see here the rows are now
strait, but the angle is still wrong. In real
life the angle of the roof is strait down and
not like this. The reason we have it like this
here is the picture. We can crop the
changes we made here now and use that to




make the angle correct. But it is better to do it right now. This saves us work.

| To correct the angle we can’t use the rotate
tool. Else we loose the changes we made
for striating out the rows. But we have a
different tool so we can keep the changes
we made with the rotate tool.
What we will use here is the skew tool.
This you can find at the transform option
of the edit menu to. Edit->Transform-
>Skew.

o Now this will change the picture a little,
| but don’t worry about that it is such a

minor change people won’t really notice.

So when we have it like we want, it is time to crop it to the part we want.

You can use the crop tool for this. I mostly use the rectangular marquee tool for this work.
But that is because | am old and use Photoshop from before the Crop tool was entered in
Photoshop. ©

L The crop tool.

Now this is what | ended up with. Pretty cool is it not? Well it sure
is. The angle is correct, and the lines are strait. So cool we have our
new texture! Or is it not so? Well see for yourself and try to use it.
Wow it works, hey that is not the case it don’t works. Where are
those strange lines come from?

Well let me tell you, the reason it don’t work is because it is not
seamless. We still need to do some minor work on it for making it like that. Now don’t close
the tutorial now! Making texture seamless is not as difficult as you think. And no | won’t use
any third party plug-in like Seamless welder from Keys Power tools. To be honest | hate the
tool and I always come to a better result doing it myself. When you know the trick you will
think the same.

A tool what many people overlook is the offset filter. Most people think it is not very useful
but in our case it is!

Look at this. It shows you what the Offset
filter can do for us. | was using a vertical
offset of -50 on this one. Notice how it made
the horizontal line visible. Now it is this line
we have to get rid of. You can find the offset
filter here. Filter->Other->Offset.

A very useful tool to work out the line is the
clone stamp tool.




Now this is the same offset. And notice you
can’t see the horizontal line anymore. | was
working it out using the Clone Stamp tool
and a soft mechanical brush of 12 pixels.
Now the trick is to set up the stamp using the
ALT key on the row above.

And use it to draw over the line we noticed
in the picture before. The result of this work
is that we made the texture seamless in the
horizontal direction. Now let’s do the same
for the vertical direction by using the same

technique. The only difference is we now
use the offset filter with a vertical displacement.

L) The clone stamp tool.

This is how it looks like when | used a
displacement of 50. Notice the thin
horizontal vertical line. We need to work this
out like we did with the horizontal line. So
have fun with your clone stamp tool.

And this is the finished result. Believe it or not but this texture is
perfectly seamless. The only thing we need to do know is making it
into a perfect square so we can use it in Game Studio.
Now for this case | don’t care too much about the size of the
individual parts, so | just resized it to 128 X 128.
And this is the texture it became. Making texture from pictures has a
different advantage to. Pictures contain a limited form of reality. This
texture has no need for bump maps when you look thro it from a
distance in the engine it gives you a 3D look. And because we don’t
really see it close we can get away whit it to.




Non repeating photo texture

In many cases you will need texture that will fill up a complete wall or block. So it won’t
repeat at all, or maybe just 1 or 2 times. Seamless texture is good in some cases like the
rooftop for example or the street. This are repeating structures in real life to, so we will use
seamless texture for those.

But the front of a house for example is lesser repetitive so seamless texture wont work in
those cases. Well not if you want it looking good and natural. Now in my London level | have
houses | want to look natural. The most important thing | want is give them a nice 3D look all
the way. But some parts like the top floor and the cellar you only see from a distance. So it
has no real use building real 3D windows in those parts. Using a photo picture what contains a
3D look from will do just fine. Because we only see them from a distance the players will see
the picture and believe it is 3D. The only thing we need to remember is when we light the
level we have to keep the light angle of the real picture in mind! Maybe | make a tutorial
about that later if you want. But for now we only concentrate on the texture.

First let me explain how I build the house in Game Studio. I did not build it from 1 block. The
texture work will save me a lot of polygons so | decided to split the house in 3 main blocks.
The bottom containing the cellar and the first floor the cellar is a part you only see from a
distance so this will be texture only, but first floor is different so | will make 3D parts like the
door and the window there. The top floor, this is never reached so this will be only texture
work. The rooftop, now you won’t reach this, but this has some big parts you will see from a
distance to like the typical English chimney and so on. But the texture for the roof we already
have. We made that in the previous part.

Part 1 the top floor texture.

We can find a new photo, but I just used the one | have used before for the rooftop. And now |
had a big question do | want it in a way it can repeat? In other words seamless. After thinking
I decided want to have it repetitive in the horizontal direction but not in the vertical way. Why
this is important you will see soon. | also wanted it on 512 X 512 so it will be really sharp in
the level.

For this work | create a new document I will use to do the work on. So let’s start with that
here to. Make a new document File->New. In the window that appears just enter 512 by 512
and keep it transparent for name fill in Top Floor. OK now we have our work document, but
for now we just minimize it.

The first thing | wanted was a window, so | opened the Photo the real one is included in the
zip file so you have the original to! Now let’s explore it for a bit. We see the houses at the left
site of the picture those are not possible to use. We look at them from an angle and this make
them completely wrong. We can only use the houses directly in front of us. Now the reason |
choose this picture is because they are on it and you can see the difference for yourself! A
golden rule when you go texture hunting is always taking your object in front. This will not
only save you a lot of work later it also will save you from huge disappointments.

Now I don’t want the windows with a balcony the reason for this is they won’t work for what
we want to do! An object like the balcony reach out to far it looks strange when we look at it
from an angle in our level. The top windows I don’t really like but when | was looking at the
house with the red door found the window | wanted the one next to the door with the white
curtains inside. So let’s steal it using the Rectangular marquee tool and the move tool like we
did with the rooftop. You can use the work document we created but | don’t advise this, a



better way is making a complete new document specially for manipulating the window. And
turn on the show grid in View->Show->Grid also like we did before.

This is what I captured from the picture. Now lets us
look at this more closely. Dam it is like the devil plays
with it! Also this window is not 100% correct it has a
slight twist when you see it with the grid.

Yes it is, and it is also time to say “Welcome in the
world of texture making!” I do this kind of things for
years and | have to tell you I only had 2 pictures | did
not need to rework in all that time. And lets be honest
this is probably the best you will ever have it just needs
some rotating.

Edit->Transform->Rotate

This is what | ended with. OK | admit | also skewed it a
tiny bit after rotating to have it as staid as possible.

~ Same thing like with the rooftop. Edid->Transform-
>Skew
Now we are ready to crop it, try to get a big part of the
material around the window, believe me you will be

— glad you did that later.

And here is my window! Now this is just a part of our texture.
What we will do now is make it appear a few times on our work
area. So we need to make this perfectly seamless. Lucky we
know a technique to do this from our rooftop texture. So Use the
Offset and Clone Stamp technique from the rooftop on this
window part to. | won’t repeat how to do this when you don’t
remember do the rooftop tutorial again. After we made the
window seamless we make the work area we minimised at the
start bigger. What we do now is use the move tool to move in 6
windows to that area. When you do it like this you will notice
you don’t need to make new layers! Photoshop will do this for
you for every window you move to the work area.

Long live Adobe Photoshop, for knowing what we want! ©

Move the window layers around so you will get the result of the next picture.



Now is that what we want or not? Yes it
everything is looking like I want it. My top |
will have 2 top floors in my house so this is
really what | want.

But what about the bottom of the texture will
it stay transparent? No it won’t! | want some
extra in this one. If we look at the house on
the picture we see something below the
balcony. And I want that on my house to, that
is why | left some room. So like always we
start with moving the selection to a work
area.

Now the part is difficult to catch on the house
we have the window from. So | used the
house next to it, that has no balcony so we
have a bigger area to capture it from. Also for
this part we need to rotate a bit and make the
sides seamless. Now don’t bother to make the horizontal seamless in this case because this
has no use! We just need it 1 time in our texture and this is at the bottom.

_ Work on it until you come up with something like this. When you do
you can move them inside your work area to just like we did for the
windows. Super it works. The only thing we still see now is where the
border texture meets the window texture.

We can use the Clone Stamp tool on this. But not like we have it now.
The best way is work out the layers in this stage and flatten the image.
Layer->Flatten Image. Now work out the irritating line. By now you
have to be a specialist in this department. When making texture this is
95% of the work we do.

So the line is out now. And we are almost done. Almost I hear you say, well yes think back on
the start of the project. We wanted it seamless in the horizontal direction and now this is not
the case. We made the windows seamless to fit together in the work area, but we did not make
the texture like we have it now seamless. So for the last part we will use the Offset filter again
and work out the last line using the Clone Stamp tool. After that we are done and we have
something what looks like this.

~Just one thing we still need to do now. Save it as a
top_floor.tga so we can use it in our levels by entering it
in our .wad file.

I really hope you have some use of my tutorial, and when
" youdo | am prepared to write some more. | enjoy it
myself and learned a lot while writing this.




Stained glass texture

At some point in our life we all come to a moment we need something special. And one of
those times is when we need stained glass. You can go out with your digital camera, go to the
local church and make pictures. Now that is a good base material, but when we look at it it’s
always a little flat.

The problem here is in the lead around the figures. If you make pictures from the inside of the
building, what is the correct thing to do by the way because then they will have the nice and
shiny look. But the problem here is the fact the bumpy look from the lead is not really like we
want. In most cases they show up like black lines, and that is not really what we want in our
3D environment. We want the bumpy look of the lead.

Now the picture | included has a different problem, the lead is showing but it is rather flat. So
| had to come up with my own technique for painting the lead on my window.

Now the cool part of this tutorial is you can use it for improving pictures of stained glass like
we use here. But a cool thing is you can also use it to make your own designs. At the end of
this tutorial I will add information how to do that.

Here you see the original | am using for the
tutorial. The original you can find in the zip file.
Notice the thing | was telling you about. The lead
is visible but it looks really flat not natural at all.
Now this is not a problem when you use it like a
picture but in a 3D environment it is not very
good. In normal cases like 3D studio or Maya we
wood correct this with a bump map. But for the
game engine we need to do it a little different.
For the engine we want to include the bump in
our texture. We can use a few techniques for this.
Capture the lead using the magic wand tool for
example. But for the tutorial here | decided to paint a new leaded layer on top. This makes it
more natural. Original those windows are made by artists and they make it freehand. When
painting the new lead on top it is also freehand so it looks also natural.

But how can we do it? Well open the picture in Photoshop and ad a new layer you can do this
using the layer menu Layer->New->Layer or just click the create new layer icon in the layers
panel. Rename this layer to leadl.

&0 This will give you something like this. What we will do

Layers "~ Channels 50 @11 now is we will change this layer in our 3 dimensional lead
paint bucked.
O+ a Yes you read correct, we will change the layer into a paint
effect, and it is really easy to do this! To start right click on
@ Lead 1 lead 1 and from the menu that appears choose Blending
= Options. This will open the blending options dialog and
g Laver® this is the tool we will use for making our lead paint effect.

And because a picture tells more then 1000 words | made
screenshots to show you the settings. ©
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The first thing to do is go to the drop
shadow panel. And insert these settings. |
use a distance of 1 because there is not
really a distance between the lead and the
glass.

Next we go to the inner glow tab and use
the settings you see here. Now this is
mostly standard so you don’t need to
change much. You can experiment with it
later, this part makes a big difference
when you play around with it.
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Now this part is one of the most important
parts of the effect we are making. This is
the part that will give our paint the nice 3
dimensional look. You can play around
whit these but | found this are the best
settings for the look we want.

One thing you have to keep for sure! Look
at the angle! It is set to 120° just the same
we used for the shadow. Change this and
the effect will loose its magic.

The last part | used is a pattern overlay.
The lead in stained glass is never strait. It
always has some pattern in it. This is
because the bending and the welding
while making the window. | use the
standard Wrinkles pattern here but you
can experiment with this to, even make
your own patterns.

Now this is all we need! We now have our
paint. And everything we paint in this
layer will use these settings!

Ok now we have our paint and we can start painting with it. But | want my 3 parts on different
layers so | started to copy my paint layer to lead 2 and lead 3. To do this right click on the

lead 1 layer and use the Duplicate Layer option.

A different option most people keep forgetting while using Photoshop is the group layers
option. Now | am a bit of a freak about grouping things together so I use it often. In this case |
made a group named Lead Paint and group my paint layers into this.

Lavars - == The advantage of the technique | am explaining here is the

yers Channels ¥ . . .

Frass Through Gpadiyi| 100% 3 fact that everything you do on the paint layers changes into
lead paint. This aspect gives you a wide range of

lock: [ &+ @ opportunities to use your creativity.

] = | started to paint over the old lead in the window on my
paint layer using a brush of 2 pixels.
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r 4l An easy way to do this job is use the navigator and

| Mavigater “tnfa MHistegram SC0 () enlarges the picture until it is really large so it is easier to
follow.

|

1Y ;Q Here you see a fragment of my work that is partly done. Notice the part |
& il ~— used the paint has much more dimension. When we started this part of the
= tutorial I told it was a good technique to design your own stained glass
texture and this is what I will show you now.

For my own design | started a new project | want it to be a texture of 256 X 256 pixels and
transparent. Then | added a layer named Lead Paint. And I used the settings for my lead paint

like before. To have a better look on what | was doing | also added a layer and filled it with a
white colour.

B = [}

— This is the layers tab I started my work with. | selected the
l Layors G ~ ® | ead Paint layer and start drawing my design on this. The
[ Merml 4 opacty: 100 [ \white work background, | will remove later from the

Lock: [ & b @ Fil:| 100% [ ]| project is a big help now so | can see what | am drawing

: much better.
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After playing around with it I came up with this
design. Like you notice it already has the lead effect
we need in our Stained Glass window. We can use
the Magic Wand tool to select the glass parts. And

/-—/7\% we use the paint bucked to fill them with the colour
we want. Start a new layer for every colour so we

\ can give every colour a different treat later. Those

/)-—‘ layers need to be below the Lead paint layer.

Now the trick here is we have to make the selection a little
bigger. Now I used a brush of 2 pixels here, so after
selecting the parts you want use the Select->Modify-
>Expand option and use a expand of 1 pixel.

You can use the shift button while selecting with the Magic
Wand tool to select all parts of the same colour at ones.

Here you see my design with the colours in place.
Like you can see it already starts to have the look
we wanted. What we will do now is play around
with the glass parts and gives them a nice natural
look.



Now I did not use a glass filter here. | came up with
this just using the satin and pattern from bending
options.

Like you can see here this also gave it a cool natural
glass look. Turning it into a stained glass window
we can use for our levels. Try some experimenting
with the technique and you will come up with some
really cool looking windows by yourself.
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